Yak Shaving With wxJSON and wxWidgets

weekend of yak shaving:

I was trying to setup autoconf and a configure script for DeskNewsBlur and noticed that there had been a new stable release of wxWidgets, so of course I had to upgrade. I grabbed the source code, compiled it and installed it them realized I would also have to recompile wxJSON to use it. Unfortunately the library hasn’t been updated in a while and would only work with GTK 1 or 2, not with 3 which is what the latest stable release of wxWidgets can use.

I had to update the configure script of wxJSON and it worked.

…that took me a day just to get DeskNewsBlur compiling again, I didn’t even work on the code just the yak shaving of using the latest wxWidgets release and writing up an Autoconf script.

Comments are Closed